Beberapa hari ini sedang mencoba template untuk membuat grafik pada pemrograman PHP yaitu JpGraph. Untuk detailnya apa itu JpGraph silahkan googling saja ya 😀 bukan itu yang mau saya bahas. Tetapi ada hal yang cukup mengganggu saat sedang mengembangkan JpGraph ini yaitu seringnya muncul pesan error. Pesan errornya adalah seperti ini. “Empty input data array specified for plot. Must have at least one data point.”

JpGraph Error Message 25092

Pesan Error JpGraph 25092

Selain itu muncul juga pesan seperti ini

There is either a configuration problem with TrueType or a problem reading font file. Make sure file exists and is in a readable place for the HTTP process. (If ‘basedir’ restriction is enabled in PHP then the font file must be located in the document root.). It might also be a wrongly installed FreeType library. Try uppgrading to at least FreeType 2.1.13 and recompile GD with the correct setup so it can find the new FT library.”

Perlu diketahui saya menemukan error ini saat mengembangkan aplikasi di server lokal laptop yang mana menggunakan Apache. Setelah bingung googling mencari solusinya ternyata setelah iseng mencoba mudah juga menanganinya yaitu jika menemukan error seperti ini di JpGraph tinggal ON/OFF Apache aja alias direstart. Setelah itu error tidak muncul lagi. Silahkan dicoba! 😀

Leave a Reply

Your email address will not be published. Required fields are marked *